Updated headset information for USB Audio CTS Tests 音频测试

Headset information for USB Audio CTS Tests on source.android.com has been updated with headsets approved and known to be compatible with associated CTS tests. Due to the short notice of peripheral update, CTS Verifier 8.0 R11 and CTS Verifier 8.1 R7 releases will not be enforced. However, we encourage the use of CTS Verifier 8.0 R11 and 8.1 R7 releases, if partners are already using the newly listed compatible headsets. Partners should update audio peripherals soon according toUSB Audio CTS Tests, as they will be necessary when running CTS Verifier 8.0 R12 and 8.1 R8 releases.

继续阅读“Updated headset information for USB Audio CTS Tests 音频测试”

Test suites and GMS releases required-use date

Test suites and GMS releases required-use date

This month we have updated releases for the test suites listed below, as well as the GMS package itself.

These versions will be required for GMS approvals as described in the table below:

Release

Release version

Required-use date

CTS

8.1 R8, 8.0 R12, 7.1 R20, 7.0 R24, 6.0 R31

2018-9-20

VTS

8.1_r5, 8.0_r8 w Sept SPLs

2018-9-20

GMS

8.1_201808, 8.0_201808

2018-10-16

CTS August releases are available

CTS August releases are available

The Android Compatibility Test Suite (CTS) August releases for Android 8.1, 8.0, 7.1, 7.0 and 6.0 are available on the CTS Downloads page of source.android.com. These releases contain continuous improvements of tests and test infrastructure and verify security patches up to July 2018 Public Security Bulletin.

Details are available in the following change lists:

继续阅读“CTS August releases are available”

针对CTS,GTS测试过程中,在profile_provisioning流程分析与常见解决方案

[DESCRIPTION]

由于目前所有的手机都要求支持Android for work, 客户在测试CTS,GTS过程中,经常在profile_provisioning的过程中出错,这边对经常出错的地方进行分析,并提供对应的解决方案

[SOLUTION]

继续阅读“针对CTS,GTS测试过程中,在profile_provisioning流程分析与常见解决方案”

广升ADUPS FOTA 过认证信息更新

- ADUPS has recently released a patched version for com.adups.fota (version 5.22), that must be used for all new builds submitted to Google

- Google will continue rejecting and blocking any new build(s) submitted with com.adups.fota version 5.16 or older

- If you are using ADUPS as your FOTA provider, updates will be pushed to devices already active in the ecosystem automatically and no further action is required for those devices

- All new builds submitted to Google from hereon need to use ADUPS com.adups.fota version 5.22 or newer, or need to use an alternative FOTA solution